version (): var

Returns Zorro's version number with two digits behind the decimal.

require (var Version): int

Returns nonzero when Zorro's version number is equal or higher than Version, otherwise prints an error message and returns 0. Give a negative Version number when Zorro S is also required.

Example:

if(version() < 2.14) {
  quit("Zorro 2.14 or above needed for this script!");
  return;
}

if(!require(-2.14)) return; // need Zorro S 2.14 or above

See also:

printf, run, wait, quit

► latest version online